您的足迹:首页 > 未分类 >kubernetes安装时docker报错

kubernetes安装时docker报错

环境: Centos 7  Docker版本:docker-ce.x86_64 0:18.03.0.ce-1.el7.centos
运行命令:yum install -y kubernetes
错误:Error: docker-ce conflicts with 2:docker-1.13.1-53.git774336d.el7.centos.x86_64

错误原因:(https://stackoverflow.com/questions/44891775/kubernetes-installation-on-centos7)
According to the documentation, Kubernetes is not yet compatible with docker-ce (docker >=17.x)
On each of your machines, install Docker. Version 1.12 is recommended, but v1.10 and v1.11 are known to work as well. Versions 1.13 and 17.03+ have not yet been tested and verified by the Kubernetes node team.

解决方法:卸载docker-ce
1、查看安装过的docker:yum list installed | grep docker
2、卸载docker:yum remove -y docker-ce.x86_64 0:18.03.0.ce-1.el7.centos
3、删除容器镜像:rm -rf /var/lib/docker

再次安装kubernetes,安装成功,而且会自动安装docker
本博客所有文章如无特别注明均为原创。作者:admin
版权所有:《电光石火》 => kubernetes安装时docker报错
本文地址:http://www.ilkhome.cn/?post=466
欢迎转载!复制或转载请以超链接形式注明,文章为 admin 原创,并注明原文地址 kubernetes安装时docker报错,谢谢。

相关推荐

版权所有:《电光石火》 => kubernetes安装时docker报错
本文地址:http://www.ilkhome.cn/?post=466
欢迎转载!请注明,文章均为 《电光石火》 原创,并注明本文地址,谢谢。


发表评论

路人甲 表情
看不清楚?点图切换 Ctrl+Enter快速提交

网友评论(0)